Aide:Éditeur Visuel

De Wikimedica
Aller à : navigation, rechercher
Si vous désirez tester l'ÉditeurVisuel, vous pouvez le faire sur votre page de brouillon.
VisualEditor-logo-fr.svg

L'Éditeur Visuel est une technologie développée par la fondation Wikimedia pour ses projets wikis. Il permet la création et l'amélioration de pages en passant par une interface similaire aux logiciels de traitement de texte auxquels sont habitués la plupart des utilisateurs. L'édition en wikicode constitue l'autre alternative, bien plus puissante, mais qui demande un peu plus de temps à apprendre.

Édition avec l'Éditeur Visuel

1 À savoir avant d'éditer une page

Une page web n'est pas un document Word
Oubliez en bonne partie les règles de présentation des documents de traitement de texte, elles ne s'appliquent que peu au web :
  • l'information ne doit pas être dupliquée ;
  • le style doit être standardisé et suivre des conventions ;
  • vous avez accès à toute une foule d'outils (liens, modèles, etc.) pour enrichir les pages, utilisez-les ;
  • ayez une pensée pour les utilisateurs de tablettes et de téléphones mobiles.

2 Copier-coller sans format

Voici probablement une astuce qui vous sauvera bien du temps !

L'Éditeur Visuel permet de copier-coller du contenu d'une source extérieure. Par contre, si vous effectuez un copier-coller standard (Ctrl + C puis Ctrl + Vsur Windows ou Cmd + C puis Cmd + V sur Apple) d'une source externe vers l'Éditeur Visuel, ce dernier recréera le format d'une manière très rudimentaire.

Simplifiez-vous la vie et copier-coller votre texte en effaçant la mise en forme du document source avec les commandes Ctrl + Shift + C puis Ctrl + V sur Windows ou Cmd + C puis Cmd + Shift + V sur Apple. En effaçant la mise en forme du document source, ce sera beaucoup plus rapide, c'est garanti !

3 Accéder à l’Éditeur Visuel

Pour modifier une page avec l’Éditeur Visuel, cliquez sur l’onglet « Modifier la page » en haut de la page.

Le chargement de la page en mode édition peut prendre plusieurs secondes, voire davantage si la page est très volumineuse.

Cliquer sur l’onglet « W » ouvrira l’éditeur classique de wikicode.

VisualEditor - Edit tab - fr.png

Vous pouvez également accéder à l’Éditeur Visuel en cliquant sur le lien « modifier » de chaque section.

VisualEditor - Section edit links - fr.png

4 Barre d’outils

Copie d’écran de la barre d’outils de l’Éditeur Visuel.

La barre d’outils de l’Éditeur Visuel apparaît en haut de l'écran lorsque vous commencez à modifier la page.

Cliquer sur le chevronVisualEditor - Icon - Expand.svg ouvrira un menu déroulant. Le chevron est toujours situé à droite du nom du menu déroulant correspondant.
La barre d'outils contient quelques icônes familières :


VisualEditor - Toolbar - Undo-redo.png

Annuler et Refaire les changements que vous venez d'effectuer (« undo » et « redo » en anglais).

  • Raccourci clavier pour annuler une action : Cmd + Z (Apple)
  • Raccourci clavier pour rétablir une action : Cmd + Y ou Cmd + Shift + Z(Apple)

VisualEditor Toolbar Headings-fr.png
Ce menu déroulant vous permet de changer le format du texte.

Pour changer le style d’un paragraphe, placez le curseur à la ligne que vous désirez modifier et sélectionnez un élément dans ce menu : vous n’avez pas besoin de mettre en surbrillance le texte que vous désirez modifier.

Les titres de section sont intitulés « Titre de section » et les sous-sections sont « Sous-titre 1 », « Sous-titre 2  » et ainsi de suite. Le format normal pour le texte est « Paragraphe ».

La page Aide:Conventions vous en apprendra davantage sur les conventions d'utilisation des différents titres et sous-titres.

N'essayez pas de créer des titres et sous-titres en ajoutant vous-même les caractères gras, soulignés ou italiques !
L'utilisation de titres pré-programmés permet de construire automatiquement la table des matières, de maintenir les fonctions d'inclusions et un style uniforme sur tout Wikimedica.

VisualEditor Toolbar Formatting-fr.png

Mise en forme

Cliquer sur le bouton « A » ouvre un menu déroulant. Vous devez avoir d’abord sélectionné (en surlignant) du texte pour qu’un formatage soit appliqué.

  • L’icône « Gras » (G) met en gras le texte sélectionné.
  • L’icône « Italique » (I) met en italique le texte sélectionné.
  • L’icône « Exposant » (x2) rend le texte sélectionné plus petit que le reste du texte et légèrement surélevé.
  • L’icône « Indice » (x2) rend le texte sélectionné plus petit que le reste du texte et légèrement abaissé.
  • L’icône « Barré » (S) barre le texte sélectionné.
  • L’icône « Code informatique » (deux accolades : {}) modifie la police de caractères du texte sélectionné en police à chasse fixe, ce qui le distingue du reste du texte en police proportionnelle.
  • L’icône « Souligné » (U) ajoute une ligne sous le texte sélectionné.
  • L’icône « Langue » (Aあ) vous permet de marquer la langue (par exemple le japonais) et la direction (par exemple de droite à gauche) du texte sélectionné.
  • La dernière icône (VisualEditor MediaWiki theme clear icon bitmap.png), appelée « Effacer le style » retire tout le formatage du texte sélectionné, y compris les liens.

VisualEditor - Toolbar - Linking.png

Lien hypertexte

La chaîne est l’outil de liens hypertextes. En cliquant sur cet onglet, la boîte de dialogue des liens s'ouvre. Cette option permet de produire des liens hypertextes entre les pages de Wikimedica ou vers des sites web externes.



VisualEditor citoid Cite button-fr.png
Source et note

Cette fonction est utilisé3 pour ajouter des références (sources) ou des notes de bas de page dans le texte sous la forme : [1].

Cet icône permet d'accéder à trois options :

  1. Automatique
    • Pour citer un site web, un ouvrage ou un article en utilisant différentes méthodes d'identification uniques.
  2. Manuel
    • Pour citer un site web, un ouvrage, un article, ou ajouter une Autre référence ou note. Il faudra remplir manuellement les champs. Cet onglet permet de mettre une référence dans le cas où l'insertion automatique ne fonctionnerait pas pour diverses raisons.
  3. Réutilisation
    • Pour réutiliser une référence ou une note déjà présente sur la même page.

Pour insérer une nouvelle référence dans un article, il y a deux choix : l'insertion automatique (plus facile) ou l'insertion manuelle.

Pour obtenir de plus amples informations sur la citation des sources sur Wikimedica, consultez la page d'aide sur les références et les notes­.


VisualEditor Toolbar Lists and indentation-fr.png

Listes et indentation

Les deux premiers icônes vous permettent d’insérer respectivement une « Liste à puces » et une « Liste numérotée ». Les deux icônes suivantes servent à augmenter ou réduire d’un cran le niveau d’indentation du texte. Il est possible d'entremêler les listes à puces et numérotées comme suit:

  • item 1;
    1. item 1;
    2. item 2;
  • item 2.

Menu insérer de l'Éditeur Visuel (capture d'écran).png

Insérer : le menu déroulant « Insérer » permet d’insérer plusieurs éléments.

  • L’icône « Média » (une image de montagnes) ouvre la fenêtre des fichiers multimédias.
  • L’icône « Modèle » (une pièce de puzzle) vous permet d'ajouter des modèles à une page.
  • L’icône « Tableau » (un tableau) vous permet d’insérer un tableau. Vous pourrez après la création ajouter une légende, fusionner des cellules ou supprimer le tableau en utilisant le bouton Tableau à droite du bouton Insérer.
  • L’icône « Commentaire » (un phylactère) vous permet d’insérer des commentaires qui ne sont pas visibles pour les lecteurs. Ces commentaires ne peuvent être vus que lors de l’édition de l’article et sont alors indiqués par une icône de point d’exclamation.
  • L’icône « Votre signature » (une signature) vous permet d’insérer votre signature. La signature est particulièrement importante sur les pages de discussion et dans la gestion des tâches.
  • L’icône « Galerie » (un ensemble de photos) vous permet d’insérer une galerie sur la page.
  • L'option « Bloc de code » vous permet d'insérer du code informatique.
  • L’icône « Liste des références et notes » (trois livres) ouvre une boîte de dialogue où vous pouvez spécifier l’endroit où les références seront affichées pour le lecteur. Vous n’aurez normalement besoin d’utiliser cette boîte de dialogue qu'une seule fois par page (ou deux s'il y a des notes).

VisualEditor Toolbar SpecialCharacters-fr.png

Insertion de caractères spéciaux

Lorsqu’on clique sur l’icône « Caractères spéciaux » (Ω), une boîte de dialogue apparaît, affichant plusieurs caractères spéciaux. En cliquant sur un caractère donné, vous le placez dans le texte. Il s’agit de certains symboles standards (par exemple, ↑↓←→), de lettres accentuées et de symboles mathématiques.


VisualEditor More Settings-fr.png

Le menu « Options de page » VisualEditor - Icon - Menu.svg est à gauche du bouton « Enregistrer la page ». Ce menu comprend des options pour ajuster les paramètres de la page, tels qu’indiquer si la page est une redirection ou comment elle doit être indexée, ainsi que pour ajouter, modifier et supprimer des catégories.


VisualEditor bi-directional switching square brackets icon.png Vous pouvez aussi basculer de l’Éditeur Visuel vers l’éditeur classique de wikicode. Veuillez noter que vous pouvez basculer de l'Éditeur Visuel vers l'éditeur classique sans perdre votre travail d’édition, mais vous perdrez toute modification si vous basculer de l'éditeur classique vers l'Éditeur Visuel.

5 Enregistrer ses modifications

Il est important d'enregistrer souvent vos modifications. Prenez l'habitude d'enregistrer à chaque fois que vous écrivez quelques phrases. Personne n'est à l'abri d'un bogue !

Lorsque vous avez terminé de modifier la page, cliquez sur le bouton bleu intitulé « Enregistrer les modifications… » dans la barre d’outils. Si vous n’avez pas fait de modification, le bouton sera désactivé (grisé). Pour annuler tous vos changements, fermez simplement la fenêtre du navigateur.

VisualEditor cancel save-fr.png

Cliquer sur le bouton bleu « Enregistrer la page » ouvre une boîte de dialogue. Vous pouvez y entrer un bref résumé de vos modifications, marquer votre modification comme mineure et ajouter la page à votre liste de suivi.

Vous pouvez vérifier vos modifications en utilisant le bouton « Relire vos modifications » pour être sûr qu’elles sont bien comme prévu avant d’enregistrer vos modifications

Le bouton « Annuler » vous renvoie vers la page que vous modifiez. Vous pouvez sauvegarder vos modifications plus tard.

Il est important d'apposer un résumé à vos modifications, cela permet aux autres éditeurs de savoir quels changements vous avez fait sur la page.

Un bon résumé de modifications permet aux autres éditeurs d'avoir un aperçu de votre dernier changement.

  • « travail » (mauvais)
  • « corrections » (mauvais)
  • « ajout d'un symptôme » (bon)
  • « correction d'une faute d'orthographe » (bon)
Qu'est-ce qu'une modification mineure ?

Lorsque vous sauvegardez une page, Wikimedica enverra des alertes à tous les utilisateurs possédant cette page dans leur liste de suivi. En identifiant votre modification comme mineure, aucune alerte ne sera envoyée. Choisissez cette option lorsqu'il est certain que votre modification n'est que superficielle :

  • correction d'une faute d'orthographe ;
  • ajout d'un saut de ligne ;
  • ajout d'un lien ;
  • etc.
VisualEditor save dialog-fr.png

6 Modifier des liens

VisualEditor - Toolbar - Linking.png
Les liens peuvent être ajoutés grâce à l’icône « Lien » (des maillons de chaîne) dans la barre d’outils ou en utilisant le raccourci clavier Ctrl + K (ou Command + K sur un Mac).

Si vous sélectionnez (surlignez) du texte puis que vous cliquez sur le bouton « Lien », un lien sera ajouté en utilisant ce texte. Pour les liens d’un seul mot, il suffit de le faire quand le curseur est sur ce mot.


VisualEditor - Link editing inline 2 - fr.png
Quand vous utilisez l’icône ou le raccourci clavier, une boîte de dialogue s’affiche afin que vous entriez le lien.

L’Éditeur Visuel vous aidera pour les liens internes en recherchant des titres probables lorsque vous commencez à taper.

Le texte affiché correspond au texte surligné avant de cliquer sur l’icône « Lien » (maillons de chaîne).


VisualEditor - Link editing inline box-fr.png
Une fois que vous avez entré ou sélectionné le lien, vous allez compléter la création du lien en cliquant le bouton « Terminé » ou simplement en cliquant hors du cadre. Votre lien apparaîtra immédiatement sur la page dans l’Éditeur Visuel, mais il ne sera pas sauvegardé tant que vous n’aurez pas enregistré la page complète.

VisualEditor - External link - fr.png
Pour lier une page d’un site internet externe à Wikimedica, le processus est identique : entrez simplement l’URL dans le champ et le lien sera ajouté en tant que « Lien externe ».

VisualEditor - Link editing inline - fr.png
Pour modifier ou supprimer un lien existant, cliquez dans le texte du lien, puis cliquez sur l’icône « Lien » qui apparaît juste à côté. La boîte de dialogue de modification va apparaître.

Dans la boîte de dialogue, vous pouvez ensuite modifier la cible du lien. Vous pouvez aussi le supprimer entièrement en cliquant sur le bouton « Supprimer » dans le coin inférieur gauche de la boîte de dialogue. Vous pouvez aussi ouvrir la cible du lien dans une autre fenêtre en cliquant dessus. (Vous voudrez probablement réaliser cela pour vérifier qu'un lien externe est valide.)


7 Modifier des références ou notes

Wikimedica ne fait pas la différence entre une référence et une note de bas de page. Une note étant seulement une référence appartenant au groupe « note».

7.1 Modifier une référence ou note existante

VisualEditor - Editing references 1 - fr.png

Pour modifier une référence existante, cliquez dessus à l’endroit où elle apparaît dans le texte (généralement un nombre). Selon le type de référence, cliquer sur cette icône va ouvrir un mini-éditeur où vous pouvez modifier la référence avec une formulaire pour les références de type article, ouvrage et site web, ou une boîte d'édition pour les autres types de références et notes.


VisualEditor - Editing references 6 - fr.png

L'interface pourra ouvir un mini-éditeur dans lequel vous pouvez modifier le contenu de la référence ou de la note. Une même référence peut contenir plusieurs modèles.

Si vous tentiez de modifier une note, « note » sera indiqué dans le champ « Références générales ».

Wikimedica utilise des modèles pour mettre en forme les références. Si un modèle est utilisé dans votre référence, tout le texte contenu dans le modèle sera surligné lorsque vous cliquerez sur les informations de la référence.

Si un modèle a été utilisé et que vous cliquez sur le texte de ce modèle, l’icône « Modèle » (une pièce de puzzle) apparaîtra. Cliquez dessus pour changer le contenu du modèle dans le mini-éditeur.


VisualEditor - Editing references 5 - fr.png

Dans le mini-éditeur de modèle, vous pouvez ajouter ou enlever des informations ou modifier le contenu. Seuls les champs (les paramètres du modèle) ayant du contenu sont normalement montrés initialement. Pour ajouter des champs, cliquez sur « Ajouter plus d’informations » en bas du mini-éditeur.


VisualEditor - Apply changes - fr.png

Cliquez sur « Appliquer les modifications » quand vous avez terminé.

7.2 Insérer une nouvelle référence ou note

Citer1.PNG

Pour ajouter une référence en utilisant le menu « Source et note », placez votre curseur là où vous souhaitez insérer la référence dans le texte, cliquez ensuite sur "Source".

Menu Source et note : il est utilisé pour ajouter des références ou notes dans le texte (sous la forme [1] ou [note 1]).

Il y a 3 onglets : Automatique, Manuel, Réutilisation.

Pour insérer une nouvelle référence dans un article, il y a 2 choix : l'insertion automatique (plus facile) ou l'insertion manuelle. Pour insérer une note, il faut passer par l'insertion manuel.

L'onglet Réutilisation sert uniquement dans le cas où la référence ou note se trouve déjà dans l'article

7.2.1 1- Insertion automatique de la référence (le plus simple)

Citer2.PNG

Insertion automatique de la référence : pour citer un site web, un ouvrage ou un article; en utilisant l'onglet Automatique du menu «Source et note ».

Pour ajouter une référence en utilisant le bouton « Ajouter une référence ou une note », placez votre curseur là où vous souhaitez insérer la référence dans le texte, cliquez ensuite sur Source et note.

Si vous souhaitez une note détaillée, choisissez « Autre référence ou note ». Ainsi, si vous souhaitez utiliser un Ouvrage comme référence, mais en précisant une citation de l'ouvrage, il vous faudra choisir Autre référence (et dans l'éditeur de référence, ajouter les modèles Ouvrage).

7.2.2 2- Insertion manuelle de la référence

7.2.2.1 Pour citer des sites web, articles, ouvrages
Citer3.PNG

L'insertion manuelle de la référence permet d'ajouter une source lorsque l'onglet « Automatique » ne fonctionne pas ou n'est pas approprié. Il faudra remplir manuellement les champs.

Autre référence ou note permet d'insérer une note de bas page personnalisée.


VisualEditor - Editing references - Cite book required fields.png

Cliquer sur une icône de modèle comme « Ouvrage » vous amène dans le mini-éditeur de modèle pour celui-ci. Les champs obligatoires sont marqués avec un astérisque, les plus utilisés sont affichés par défaut, mais peuvent être laissés vides.


VisualEditor - Editing references - Add parameter.png

Pour ajouter d'autres paramètres, descendez dans l'éditeur de modèles miniature et cliquez sur l'option « Ajouter plus d’informations ».

Cliquez sur « Insérer » lorsque vous avez terminé.

7.2.2.2 Citer une source en utilisant « Autre référence ou note »
VisualEditor - Editing references 20 - fr.png

Dans l’éditeur de références, vous pouvez modifier ou mettre en forme la ou la référence note.

Si vous voulez ajouter une note, assurez-vous qu'elle fait partie du groupe « note».

VisualEditor Template Insert Menu-fr.png

Dans l’éditeur de référence, si vous souhaitez inclure un modèle dans la référence, cliquez sur l’icône « Modèle » (une pièce de puzzle) dans la barre d’outils déroulante « Plus » de l’éditeur de références.


VisualEditor - Editing references 9 - fr.png

Ensuite, cherchez le modèle que vous voulez insérer, ajoutez-le et modifiez-le de la même façon que pour n'importe quel autre modèle (voir la section Modifier des modèles ci-dessous si vous avez besoin de plus d'information sur les modèles).

Après avoir fini de modifier votre nouveau modèle, cliquez sur « Appliquer les modifications » pour retourner à l’éditeur de référence, puis de nouveau sur « Appliquer les modifications » pour revenir à la page que vous modifiez.


VisualEditor Reference List Insert Menu-fr.png

S’il n’y a pas encore de liste de références ou notes sur la page (par exemple, si vous êtes en train d’ajouter la première référence), vous devez l’ajouter afin d’afficher le texte de votre référence.

Placez votre curseur là où vous souhaitez afficher la liste de références (habituellement en bas de page), ouvrez le menu « Insérer » et cliquez sur l’icône « Liste des références et notes » (trois livres) pour l’ajouter.

Selon les conventions, la liste de notes doit être précédée d'un titre de section « Notes ».

Selon les conventions, la liste de référence doit être précédée d'un titre de section « Références ».


VisualEditor - Editing references 11 - fr.png

Si vous ajoutez la liste des notes, spécifiez « note » comme groupe.

La dernière étape consiste à cliquer sur « Insérer » dans la boîte de dialogue de la liste de références.

7.3 Réutiliser une référence ou note existante

Citer1.PNG

Citer4.PNG

Réutilisez une source avec l'onglet « Réutiliser » du menu « Ajouter une référence ou une note » :

(quelle que soit la référence : ouvrage, site web, article ou « Autre référence ou note »)

Dans le cas où la référence se trouve déjà dans l'article, vous pouvez réutiliser la référence déjà existante.

Pour réutiliser une référence existante, placez votre curseur là où vous souhaitez l’insérer dans le texte puis cliquez sur le bouton « Réutiliser » du menu « Ajouter une référence ou une note ».


VisualEditor - Editing references 18 - fr.png

Dans la boîte de dialogue « Ajouter une référence ou une note », cherchez la référence ou note que vous souhaitez utiliser dans la liste et sélectionnez-la. S’il y a de nombreuses références ou notes, vous pouvez utiliser le champ de recherche (marqué « Chercher dans les références et notes actuelles ») pour n’afficher que les références ou notes qui incluent un texte donné.


8 Modifier des images et d’autres fichiers multimédias

8.1 Ajouter une image ou un fichier multimédia

Pour ajouter une image existante (ou un autre fichier multimédia) à la page, cliquez sur l’icône « Média » (une image de montagnes) dans le menu déroulant « Insérer ». L’image sera ajoutée au niveau de votre curseur.

VisualEditor Media Insert Menu-fr.png

Commons-logo.svg
Commons-logo.svg
À partir de Wikimedica, il est possible d'accéder à la librairie Commons où plusieurs dizaines de millions d'images et autres média libre de droits sont disponibles.

Cliquer sur l’icône « Média » ouvre une boîte de dialogue qui vous permet de chercher des fichiers multimédias en relation avec la page que vous éditez, simultanément dans le Wiki de votre langue et sur Wikimedia Commons.

Vous pouvez chercher d’autres fichiers en changeant le texte situé dans la barre de recherche de cette boîte de dialogue.

Cliquez sur une vignette pour sélectionner un fichier.

Cela place l'image dans la page que vous éditez.

VisualEditor - Media editing 2 - fr.png

Une fois que l'image sélectionnée est insérée dans la page, une autre boîte de dialogue s'ouvre. Elle vous permet d'ajouter ou de modifier une légende, qui peut également être mise en forme et contenir des liens.

VisualEditor - Media editing 6 - fr.png

La boîte de dialogue média vous permet aussi d'ajouter une légende texte alternative à la photo pour les utilisateurs utilisant des lecteurs d'écran.

VisualEditor - Media editing 7.png

Vous pouvez aussi configurer divers paramètres de l'image dans la fenêtre « Paramètres avancés », notamment l'alignement, la mise en page (« type ») et la taille de l'image.

VisualEditor - Media editing 8.png

Quand vous avez terminé, cliquez sur « Appliquer les modifications » pour fermer la boîte de dialogue et retourner à l’édition de la page.

VisualEditor - Apply changes - fr.png

8.2 Modifier une image ou un fichier multimédia

Pour une image existante, vous pouvez ajouter ou modifier une légende ou d'autres paramètres en la sélectionnant, puis en cliquant sur l'icône « Média » qui apparaît sous l'image.

Vous pouvez retailler une image existante en cliquant dessus, puis en tirant l'icône d'ajustement de taille (la flèche à deux têtes en bas à gauche de l'image).

Vous pouvez aussi glisser-déposer une image à un autre endroit de la page.

VisualEditor - Media editing 3 - fr.png

Quand vous avez terminé, cliquez sur « Appliquer les modifications » pour fermer la boîte de dialogue et retourner à l’édition de la page.
VisualEditor - Apply changes - fr.png

8.3 Modifier des galeries de médias

Pour ajouter une nouvelle galerie, cliquez sur l’icône « Galerie » (un groupe de photos) dans le menu « Insérer ». Menu insérer de l'Éditeur Visuel (capture d'écran).png

Pour modifier une galerie existante dans l’Éditeur Visuel, cliquez sur celle-ci, puis cliquez sur l’icône « Galerie » (un groupe de photos) vers le bas de la galerie. Apparaît alors l’éditeur de galerie avec la liste complète des images incluses dans cette galerie.

VisualEditor - Gallery2.png

Commons-logo.svg
Commons-logo.svg
À partir de Wikimedica, il est possible d'accéder à la librairie Commons où plusieurs dizaines de millions d'images et autres média libre de droits sont disponibles.

Le premier onglet nommé « Images » permet l'ajout d'images à la galerie. Pour qu'une image soit disponible, elle doit préalablement avoir été ajoutée au wiki. Contrairement à l'ajout d'images, il n'est pas possible de téléverser une image par l'éditeur de galerie.

Le deuxième onglet nommé « Options » vous permet de régler les options de la galerie comme la taille des images, le titre, etc.

Lorsque vous cliquez sur le bouton « Terminé » ou « Insérer » (dans le cas d'une nouvelle galerie), vous quittez l’éditeur de galerie. Vous devriez ensuite voir les modifications effectuées sur la galerie et le résultat comme il apparaîtra aux autres lecteurs.

Souvenez-vous que quitter l'éditeur de galerie ne sauvegarde pas vos modifications. Comme pour les autres autres modifications réalisées avec l'Éditeur Visuel, vous devez sauvegarder la page entière pour que tout votre travail soit sauvegardé.

VisualEditor - Gallery3.png

8.4 Télécharger une nouvelle image

Page principale: Aide:Importation de fichiers
En raison du droit d'auteur, le téléchargement d'une nouvelle image est une opération qui comporte certaines complexités. La page Aide:Importation de fichiers vous guidera lors de ce processus. Assurez-vous de bien la lire et la comprendre, toute image contrevenante pourra être supprimée sans préavis en raison du risque de poursuites judiciaires qu'elle pourrait entraîner. Dans le doute, privilégiez l'utilisation d'images existantes.

9 Modifier des modèles

Page principale: Aide:Modèle

Pour ajouter un nouveau modèle à la page, placez votre curseur là où vous souhaitez insérer le modèle et cliquez sur l’icône « Modèle » (pièce de puzzle) dans le menu « Insérer ».

VisualEditor Template Insert Menu-fr.png

Tapez le nom du modèle que vous souhaitez insérer. Lorsque vous le voyez dans la liste, sélectionnez-le. Cliquez ensuite sur « Ajouter le modèle ».

VisualEditor - Template editing 4 - fr.png

Vous pouvez également modifier des modèles qui sont déjà sur la page en les sélectionnant (ils deviennent bleus), puis en cliquant l’icône « Modèle » (une pièce de puzzle) qui apparaît à côté.

VisualEditor - Template editing 1 - fr.png

Ajouter un nouveau modèle ou en ouvrir un existant affiche la boîte de dialogue de « Insertion d’un modèle ». Si le modèle a été mis à jour avec des métadonnées TemplateData, alors la boîte affichera une liste des paramètres disponibles; sinon un lien vers la documentation du modèle sera affiché à la place.

Si vous avez des interrogations quant à un champ, cliquez sur le symbole d'information.

Pour supprimer un champ, cliquez sur la corbeille.

VisualEditor - Template editing 2 - fr.png

Malheureusement, seul le wikicode est disponible dans le formulaire d'édition de modèle. D'ici à ce que ce ne soit plus le cas, tentez l'usage du wikicode, c'est plus simple que vous pensez...

Pour un modèle existant, vous modifiez les paramètres déjà présents et vous pouvez en ajouter d’autres en cliquant sur « Ajouter plus d’informations » tout en bas de la boîte de dialogue.

VisualEditor - Template editing 3 - fr.png

Quand vous avez terminé, cliquez sur « Appliquer les modifications » pour fermer la boîte de dialogue et retourner à l’édition de la page.

VisualEditor - Apply changes - fr.png

9.1 Les inclusions

Page principale: Aide:Inclusions
Si un modèle a en fait l'air de contenu que vous retrouvez généralement sur des pages, vous avez affaire à une inclusion, où le contenu d'une page en totalité ou en partie est inclus dans une autre page. Ceci permet d'éviter la duplication d'information. Lorsque le contenu de la page incluse change, celle qui lui fait appel est automatiquement mise à jour.
Les inclusions fonctionnent comme les modèles. Pour plus d'information sur la gestion des inclusions, consultez la page d'aide sur le sujet.
Inclusion d'une page avec l'Éditeur Visuel (capture d'écran).png

10 Modifier des tableaux

Insérer tableau.PNG

Vous pouvez utiliser l’Éditeur Visuel pour insérer et modifier des tableaux. C’est une fonctionnalité récente susceptible d’évoluer. Pour insérer un tableau, cliquez sur le menu déroulant « Insérer » puis « Tableau ». Vous pouvez également importer des tableaux en faisant un glisser-déposer d’un fichier de valeurs séparées par des virgules (.csv) depuis votre ordinateur vers la fenêtre d’édition.


VisualEditor - fr - insérer colonne.png

Vous pouvez ajouter et supprimer des colonnes et des lignes.


Contenu dans un tableau (capture d'écran).png

Double-cliquez dans une cellule pour ajouter du contenu ou le modifier.

Il n'y a pas de limite au type de contenu que vous pouvez ajouter dans un tableau.


Style de cellule, fusion de cellules et propriétés d'un tableau (capture d'écran).png En sélectionnant plusieurs cellules, d'un tableau, vous pouvez les fusionner (et scinder des cellules fusionnées)

Lorsqu'un ou plusieurs cellules sont sélectionnées, vous pouvez changer leur style pour en faire des cellules d'en-tête ou de contenu.

En cliquant sur le bouton « Propriétés » vous pouvez ajouter une légende, une fonction de tri des colonnes, désactiver le style du tableau, etc.

11 Modifier des catégories

VisualEditor - Toolbar - Page settings-fr.png
Une catégorie, comme son nom l'indique, regroupe des pages sous une même rubrique. Voici quelques exemples de catégories: Les catégories relèvent aussi d'une très grande importance pour la sémantique. Voici une liste de toutes les catégories de Wikimedica.

Pour modifier les catégories, dans le menu « Options de page » VisualEditor - Icon - Menu.svg, cliquez sur le bouton « Catégories ».


VisualEditor - Category editing 1 - fr.png

Le bouton « Catégories » ouvre une boîte de dialogue qui liste les catégories existantes et vous permet d’en ajouter d’autres.

Vous pouvez définir ou changer la clé de tri par défaut, qui est utilisée pour déterminer l'ordre d'apparition de la page dans les listes de pages par catégorie.

Par exemple, la clé de tri pour l'article « Claude Monet » est « Monet, Claude », donc dans la catégorie « Peintre impressionniste français », l'article est listé sous la lettre « M », et non la lettre « C ».


VisualEditor - Category editing 3-fr.png

Pour ajouter une catégorie à une page, tapez le nom de la catégorie dans le champ « Ajouter une catégorie ». L’Éditeur Visuel va afficher dynamiquement les catégories correspondant à ce que vous entrez.

Vous pouvez soit sélectionner une catégorie existante soit vous pouvez ajouter une catégorie qui n’a pas encore de page (la nouvelle catégorie apparaîtra rouge jusqu’à ce que la page de la catégorie soit créée).


VisualEditor - Category editing 2 - fr.png

Pour retirer une catégorie existante, cliquez dessus et cliquez sur l’icône « Supprimer » (une poubelle) dans la boîte de dialogue qui apparaît.

Sélectionner une catégorie vous permet aussi de définir une clé de tri pour celle-ci. Cette clé remplace la clé de tri par défaut.


VisualEditor - Apply changes - fr.png

Cliquez sur « Appliquer les modifications » quand vous avez terminé de modifier les catégories pour retourner à l’édition de la page.

12 Modifier les paramètres de la page

VisualEditor - Toolbar - Page settings-fr.png

Pour changer les paramètres d’une page, ouvrez le menu « Options de page » VisualEditor - Icon - Menu.svg dans la barre d’outils et cliquez sur le bouton « Paramètres de la page ».


VisualEditor Page Settings-fr.png

Le bouton « Paramètres de la page » ouvre une boîte de dialogue contenant plusieurs options.


VisualEditor Page Settings Redirects-fr.png
Page principale: Aide:Redirections

Vous pouvez transformer la page que vous éditez en une redirection vers une autre page en cochant la case « Rediriger cette page vers » et en tapant le nom de la page vers laquelle vous voulez que les lecteurs soient redirigés.


VisualEditor Page Settings TOC-fr.png

Vous pouvez activer ou désactiver l'affichage d'une table des matières en sélectionnant l'un de ces trois boutons. L'option par défaut est « Si nécessaire », qui affiche la table des matières pour trois titres ou plus.


VisualEditor - Page Settings Edit Links.png

Vous pouvez cacher les liens d'édition à coté de chaque section en cochant cette case.


VisualEditor Apply Changes-fr.png

Cliquez sur « Appliquer les modifications » lorsque vous avez terminé d’éditer le « Options de page » pour revenir à l’édition de la page.

13 Raccourcis clavier

Les utilisateurs Apple devront remplacer Ctrl par Cmd

De nombreux contributeurs sont habitués à écrire directement en wikicode, notamment lorsqu’il s’agit d’insérer du texte en gras, en italique ou un lien interne. Des raccourcis clavier permettent d’effectuer ces mêmes actions rapidement sans avoir besoin d’utiliser les boutons de la barre d’outils. Vous pouvez les consulter en cliquant le point d'interrogation « ? » dans la barre d'outils principale. Voici les raccourcis habituels dans l’Éditeur Visuel :

Raccourcis clavier de l'Éditeur Visuel.png
Le contenu de cette page d'aide a été tiré de l'aide de MediaWiki.